AI Engine – MCP Server & AI Chatbot for WordPress, with Claude, ChatGPT & Gemini

27 known CVEs 90K+ active installs

Scan My Site Free

UNKNOWN: 27
Known Vulnerabilities 27
CVE-2026-110732 UNKNOWN EPSS 0.2%
Published 2026-10-30 · Affected: ≤3.8.6 · Fixed in 3.8.6
The AI Engine – The Chatbot, AI Framework & MCP for WordPress plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 3.8.6 This is due to the MCP module's OA
CVE-2026-110732 UNKNOWN EPSS 0.2%
Published 2026-10-30 · Affected: ≤3.8.6 · Fixed in 3.8.6
The AI Engine – The Chatbot, AI Framework & MCP for WordPress plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 3.8.6 This is due to the MCP module's OA
CVE-2026-107745 UNKNOWN EPSS 0.3%
Published 2026-10-28 · Affected: ≤3.8.4 · Fixed in 3.8.4
The AI Engine – The Chatbot, AI Framework & MCP for WordPress plugin for WordPress is vulnerable to limited media file deletion due to insufficient file path validation in the upload_file function in
CVE-2026-96561 UNKNOWN EPSS 0.3%
Published 2026-10-01 · Affected: ≤3.8.0 · Fixed in 3.8.0
The AI Engine – The Chatbot, AI Framework & MCP for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 3.8.0 This is due to a chain of missin
CVE-2026-96561 UNKNOWN EPSS 0.3%
Published 2026-10-01 · Affected: ≤3.8.0 · Fixed in 3.8.0
The AI Engine – The Chatbot, AI Framework & MCP for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 3.8.0 This is due to a chain of missin
CVE-2026-89141 UNKNOWN EPSS 0.4%
Published 2026-09-15 · Affected: ≤3.7.7 · Fixed in 3.7.7
The AI Engine – The Chatbot, AI Framework & MCP for WordPress plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 3.7.7 via the 'mediaId' param
CVE-2026-89141 UNKNOWN EPSS 0.4%
Published 2026-09-15 · Affected: ≤3.7.7 · Fixed in 3.7.7
The AI Engine – The Chatbot, AI Framework & MCP for WordPress plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 3.7.7 via the 'mediaId' param
CVE-2026-1400 UNKNOWN EPSS 0.5%
Published 2026-01-28 · Affected: See advisory
The AI Engine – The Chatbot and AI Framework for WordPress plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the `rest_helpers_update_media_metadata`
CVE-2026-1400 UNKNOWN EPSS 0.5%
Published 2026-01-28 · Affected: See advisory
The AI Engine – The Chatbot and AI Framework for WordPress plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the `rest_helpers_update_media_metadata`
CVE-2026-0746 UNKNOWN EPSS 0.1%
Published 2026-01-27 · Affected: See advisory
The AI Engine plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 3.3.2 via the 'get_audio' function. This makes it possible for authenticated attac
CVE-2025-8084 UNKNOWN EPSS 0.4%
Published 2025-11-18 · Affected: See advisory
The AI Engine plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 3.1.8 via the rest_helpers_create_images function. This makes it possible for auth
CVE-2025-12844 UNKNOWN EPSS 0.4%
Published 2025-11-13 · Affected: See advisory
The AI Engine plugin for WordPress is vulnerable to PHP Object Injection via PHAR Deserialization in all versions up to, and including, 3.1.8 via deserialization of untrusted input in the 'rest_simple
CVE-2025-11749 UNKNOWN EPSS 1.0%
Published 2025-11-05 · Affected: See advisory
The AI Engine plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.1.3 via the /mcp/v1/ REST API endpoint that exposes the 'Bearer Token' value
CVE-2024-5993 UNKNOWN EPSS 0.4%
Published 2024-07-09 · Affected: See advisory
The Cliengo – Chatbot plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'update_session' function in all versions up to, and including, 3
CVE-2024-5992 UNKNOWN EPSS 0.5%
Published 2024-07-09 · Affected: See advisory
The Cliengo – Chatbot plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'update_chatbot_token' and 'update_chatbot_position' functions in
CVE-2023-51409 UNKNOWN EPSS 1.0%
Published 2024-04-12 · Affected: See advisory
Unrestricted Upload of File with Dangerous Type vulnerability in Jordy Meow AI Engine: ChatGPT Chatbot.This issue affects AI Engine: ChatGPT Chatbot: from n/a through 1.9.98.
CVE-2023-51409 UNKNOWN EPSS 1.0%
Published 2024-04-12 · Affected: See advisory
Unrestricted Upload of File with Dangerous Type vulnerability in Jordy Meow AI Engine: ChatGPT Chatbot.This issue affects AI Engine: ChatGPT Chatbot: from n/a through 1.9.98.
CVE-2023-51409 UNKNOWN EPSS 1.0%
Published 2024-04-12 · Affected: See advisory
Unrestricted Upload of File with Dangerous Type vulnerability in Jordy Meow AI Engine: ChatGPT Chatbot.This issue affects AI Engine: ChatGPT Chatbot: from n/a through 1.9.98.
CVE-2023-51409 UNKNOWN EPSS 1.0%
Published 2024-04-12 · Affected: See advisory
Unrestricted Upload of File with Dangerous Type vulnerability in Jordy Meow AI Engine: ChatGPT Chatbot.This issue affects AI Engine: ChatGPT Chatbot: from n/a through 1.9.98.
CVE-2024-0378 UNKNOWN EPSS 0.5%
Published 2024-03-02 · Affected: See advisory
The AI Engine: Chatbots, Generators, Assistants, GPT 4 and more! plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the AI chat data when discussion tracking is enabled in all versi
CVE-2024-0378 UNKNOWN EPSS 0.5%
Published 2024-03-02 · Affected: See advisory
The AI Engine: Chatbots, Generators, Assistants, GPT 4 and more! plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the AI chat data when discussion tracking is enabled in all versi
CVE-2024-0699 UNKNOWN EPSS 0.7%
Published 2024-02-05 · Affected: See advisory
The AI Engine: Chatbots, Generators, Assistants, GPT 4 and more! plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'add_image_from_url' function i
CVE-2024-0699 UNKNOWN EPSS 0.7%
Published 2024-02-05 · Affected: See advisory
The AI Engine: Chatbots, Generators, Assistants, GPT 4 and more! plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'add_image_from_url' function i
CVE-2023-5254 UNKNOWN EPSS 0.6%
Published 2023-10-19 · Affected: See advisory
The ChatBot plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 4.8.9 via the qcld_wb_chatbot_check_user function. This can allow unauthenticated att
CVE-2023-5254 UNKNOWN EPSS 0.6%
Published 2023-10-19 · Affected: See advisory
The ChatBot plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 4.8.9 via the qcld_wb_chatbot_check_user function. This can allow unauthenticated att
CVE-2023-5204 UNKNOWN EPSS 0.9%
Published 2023-10-19 · Affected: See advisory
The ChatBot plugin for WordPress is vulnerable to SQL Injection via the $strid parameter in versions up to, and including, 4.8.9 due to insufficient escaping on the user supplied parameter and lack of
CVE-2023-5204 UNKNOWN EPSS 0.9%
Published 2023-10-19 · Affected: See advisory
The ChatBot plugin for WordPress is vulnerable to SQL Injection via the $strid parameter in versions up to, and including, 4.8.9 due to insufficient escaping on the user supplied parameter and lack of

Is AI Engine – MCP Server & AI Chatbot for WordPress, with Claude, ChatGPT & Gemini running on your site?

A free scan detects your plugins and flags any that match these CVEs.

Scan My Site Free